Glitch on Uveto

Writter01

Member
Jul 5, 2022
13
2
29
So, I've been playing the game for a while now, and finally got to Uveto after ending Myrellion. fast forward, I try to start the missions in Uveto, and I start to see some game breaking bugs.
First, after trying to buy "Slepra Down Bra", the game would crash. Tried this a few times more, and got the same result, so I'd had to load my last save every time, so I decided to go off to other planet and returned later. Once I returned I was able to buy it. all cool. But it was really weird

Second, Once I tried to explore Uveto, MY WHOLE INVENTORY DISSAPEARED, I was packed with EMP grenades, vials of grey goop, the milking machines, the goo space suit and some other stuff and it all went away, both in my personal inventory and my ship invetory, it was all gone.
So, scared to lose Nova, I've retreated from Uveto for now, I havent tried the quests anymore or going to the planet, but damn, I'm just missing those quests. Can anyone tell me if they experienced the same?
 

Theron

Well-Known Member
Nov 8, 2018
3,248
1,302
43
1. Probably a bug that got fixed in a later version.

2. I've been keeping a fairly close eye on the bug reports, and I've never seen a report of anything like that. The closest is editing a save converted from Flash to resolve a certain uncommon bug. (Cannot read 'location'.)
I suggest using 'Save to File' to make a backup save, then playing around on Uveto for a while. If you come across the bug again, try to figure out what steps lead to it and report it here. Preferably with a save that can reliably produce the bug.
 

Writter01

Member
Jul 5, 2022
13
2
29
OK, I'll make a save and try again. About the editing solution, may you explain to me the steps for it in case I wanna try it?
 

Theron

Well-Known Member
Nov 8, 2018
3,248
1,302
43
I'm not sure why you'd want to try it; it just causes you to lose everything in storage and it's only to get certain bugged saves converted from Flash to load. But here are the instructions, anyway.
 

Writter01

Member
Jul 5, 2022
13
2
29
1. Probably a bug that got fixed in a later version.

2. I've been keeping a fairly close eye on the bug reports, and I've never seen a report of anything like that. The closest is editing a save converted from Flash to resolve a certain uncommon bug. (Cannot read 'location'.)
I suggest using 'Save to File' to make a backup save, then playing around on Uveto for a while. If you come across the bug again, try to figure out what steps lead to it and report it here. Preferably with a save that can reliably produce the bug.

Hello, Sorry I took so long, but I got an update about that glith in UVETO. So:
I tried to play again, travelled from New Texas to Uveto, and tried to buy some stuff, but my inventory was full, so I went about selling some stuff to Anno, and the game crashed, giving me the error on the image.

So, once I restarted, I decided to clean out my inventory (both ship and personal) and sell everthing I didn't need, since it was so full, almost to the top. I sold everything to Anno, and went on my way to Uveto. From then on, I havent experiences anymore glitches, so It may have had something to do with all the data the game had to process to keep track of my items, I don't really know
 

Attachments

  • error en UVETO 1.png
    error en UVETO 1.png
    69.7 KB · Views: 6

Theron

Well-Known Member
Nov 8, 2018
3,248
1,302
43
So, once I restarted, I decided to clean out my inventory (both ship and personal) and sell everthing I didn't need, since it was so full, almost to the top.
The apartment on Tavros has storage.
 

Gedan

BUTTS BUTTS BUTTS
Staff member
Aug 26, 2015
8,008,893
8,008,326
If you still have a save from before triggering the issue with Anno, that would be fantastic to dig into it and figure it out a bit more.
 

Writter01

Member
Jul 5, 2022
13
2
29
If you still have a save from before triggering the issue with Anno, that would be fantastic to dig into it and figure it out a bit more.
Lucky enough, I saved it into a file, just in case something happened

And I wanna point out that the bug wasnt appearing just with Anno, but at random: After purchasing thing around the Uverto Station, Getting into the Ship in Uveto. The only constant was that Uveto was always involved
 

Attachments

  • Andy (H) - 7Hrs 28Mins, 76 Days - Casstech Z14, Sindathu.json
    822.8 KB · Views: 1

Gedan

BUTTS BUTTS BUTTS
Staff member
Aug 26, 2015
8,008,893
8,008,326
Figured out one way this might be happening; it's sometimes possible to execute the accept button in the modal displayed to confirm a checkout, but re-execute the function that showed the modal in the first place - because you've already accepted it once then all of the shop state behind the scenes has been cleared out, so accepting it again will cause a crash.

Unfortunately it's proving extremely inconsistent for me to trigger so it's gonna be a pain to really dig into the root cause.