Urta and Edryn are gone? (also minor imp bug)

Not open for further replies.


New Member
Jan 3, 2016
So I've reached the end of Urta's Fertility Quest plenty of times before, however, since my PC was pregnant this time I figured I'd tell Urta to impregnate Edryn instead.(realised after reading the wiki that it wouldn't have mattered anyways but whatevs) So off Urta goes aaand...56 days later still no signs of either her or Edryn ANYWHERE. The wiki didn't say they'd be removed from the game so I'm assuming it's a bug or did I fuck up and remove Urta from the game(status tab still says Urta my "Lover")?

Also earlier in my save I tried the Lusty Maid Armor while being virgin and at one point each and every time I defeated an Imp, I had only one choice available at the victory screen "Female rape" even if I wasn't at 100lust , couldn't even chose to ignore or anything only rape(which since it took away the PC's virginity would force me to reload and avoid imps. :/ ) , I had fairly high corruption though(~40) but I don't know if that's what caused it.


Well-Known Member
Aug 27, 2015
There is a bug in the fertility quest where they both dissapear. There's a solution in this topic: https://fenoxo.com/forum/index.php?/topic/575-urta-and-edryn-missing/

The lusty armou thing though is a known bug. For some reason, the "Leave" button isn't loaded. The only way round is to avoid Explore and the Forest entirely so you don't meet imps. Or make sure you're not wearing the armour when you fight them. Or getting another option to let you end that scene a different way, either by getting the Feeder perk so you can breastfeed him, or by getting a bee oviposter so you can impregnate him with eggs.


Staff member
Aug 26, 2015
Just tested this now, seems to work fine (Female Rape, B.Titfuck and Leave were all valid options after defeating an Imp).

If it's still an issue, new report with save exhibiting the issue pls tia.
Not open for further replies.